Neues Thema starten

Entwicklungs-TSE: Zertifikat ausgelaufen

 Hallo,


heute  Morgen, dem 31.01.2019 stellte ich sehr unerfreut fest,

daß das Zertifikat des Entwicjkungssticks abgelaufen ist.

Rien ne va plus.

Ist das noch jemandem passiert und habt Ihr Abhilfe erhalten ?

Ich zumindestens keine brauchbare.

Der Tip, als Timeadmin die Zeit zu fälschen geht auch nicht wegen abgewiesenem Login.

MfG



Hallo,

mein TSE Entwicklungs-MicroSD zeigt über worm_info_certificateExpirationDate(WormInfo) den 23.03.3581 an.

Den März des Jahres 3581 deutet darauf hin, dass der Zahlenwert, der von der DLL abgerungen wurde, gleich als TDateTime interpretiert wird. Das ist falsch. Was Du bekommst, ist ein UNIX-Timestamp. Du musst den Zahlenwert also noch mit UnixToDateTime() behandeln.

Vielen Dank für den Hinweis, jetzt bin ich auch beim 30.1.2020.  Mit Deinem Hinweis aus meinem Thema "worm_tse_updateTime bringt Fehler 4106: setzen der Zeit ein Jahr zurück" ist das Problem ja gelöst.

Hallo Andreas,


Als Vorbereitung auf den Ablauf hatten wir uns die Sache etwas genauer angesehen. Wird die Zeit einmalig hinter das Ablaufdatum des Zertifikats gesetzt, so ist kein Login und keine Transaktion mehr möglich.

Abhilfe schafft bei einer Entwicklungseinheit hier der Factory Reset und das setzen der Zeit auf einen Tag vor dem Ablaufdatum. Wir haben einfach 30 Tage vom heutigen Datum abgezogen.  Wichtig dabei ist, darauf zu achten, dass niemals das Ablaufdatum überschritten wird.

Weitere Lösungsvorschläge zu dem Problem würden mich natürlich sehr interessieren, da unser bisheriger Workaround nicht gerade elegant ist.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen